
ImageFlow Detailed Tutorial:  Instant Photo Montage Animations in Final Cut Pro

There is also a version of this specific to After Effects available.





It's 6pm, you've just completed a six hour edit and you're

  looking forward to heading out and downing a favorite beverage or two. Everything's

  looking rosy, then all of a sudden the client pulls out a CD. "We took

  these stills on the shoot, can you use them as a background for the titles?"  

Panic, sweat, what to do? Call one of the After Effects artists? They've all

  gone home, or more likely they're all working on a job till late. So cut to

  six hours later and you've painfully finished cropping, resizing and hand keyframing

  50 still image layers. Your timeline is now 30 layers deep, then you hit the

  render button. Uh oh.

Ok, so is there a better way? Well, lets take a look.

ImageFlow Fx is a set of plugins for Final Cut Pro and Motion which reduce

  the complex task of creating an animated photo montage to a process which takes

  only minutes. This tutorial will run you through creating a photomontage and

  what's more, you get to keep two of the plugins absolutely free, with no watermarks

  or restrictions.

Scroll to the bottom for the links to the tutorial sample files and ImageFlow Installer



Click on Quicktime icon at left to play tutorial final result

Ok, now how to make those, it's much simpler than you think. Let's start off

  with that CDROM of random images you've been handed. It could be all different

  resolutions, size, file formats, types, even a mix of CMYK and RGB. Now you

  could straight away select that whole folder and plug it into ImageFlow Fx,

  as the plugins will handle all sorts of mixed file types and sizes (up to 4096x4096).

  If you don't care about image order or the images have already been scaled

  and sorted, then skip the next step. If you don't want to use your own, the

  Sample Project files linked below include four folders of images which are

  already scaled and sorted.

 

 

 

Optimizing and Setting Image Order with iPhoto

You can do this by hand or with any other image editing program, but everyone

  has iPhoto and there's a few tricks built into it which can save you some time.

  Start up iPhoto and select the "File -> Import to Library" menu

  option. Choose the folder of images you want to use and then let iPhoto import

  them all. Now, before you click on anything else, choose the "File -> New

  Album from Selection" option and name the album "Photomontage Selects".

  You can now use the iPhoto interface to delete images you don't want to use

  in the animation, crop, or make any needed level adjustments. Drag the order

  of the images to be the order you want in your animation as well. When your

  album contains only the pictures you want in the order you want, then choose "Edit

  -> Select All"



Apple changed the way image numbers are padded in iPhoto 08, so you have to use two different techniques depending
on which version you are using:



If you have iPhoto '07













Export settings in iPhoto 07

Change the default settings for the export, select "scale images no larger

  than" and enter a resolution that
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  is just higher than your Final Cut Pro project resolution. For example if you

  are working in a PAL or NTSC project, then try the images scaled to 800 pixels

  wide and let iPhoto preserve the aspect ratio. For HD projects use either 1500

  pixels wide for HDV or 2048 if you are working in uncompressed HD.

Then, it's very important to change the Name option from "Use Filename" to "Use

  Album Name", this will export the images with names which keeps the order

  you choose in the iPhoto Album. Now hit the export button, then make a new

  folder on the desktop called "Photomontage selects" and hit "OK". 







If you have iPhoto '08














First use from the menus "Photos->Batch Change->Title to Text" as shown at left

With all the images in the album selected, sequentially rename them using the menu option "Photos->Batch Change-
>Title to Text" with attach number to each file checked.






















Export settings in iPhoto 08

 Then export using the File->Export->File Export menu option and select custom size option, and enter a width just wider
than your project resolution, then change filename to the "Use Title" option. That will give you file names as "filename-
01.jpg", etc. correctly padded with zeros so the images will be in the same order in ImageFlow as they are in the iPhoto
album.







Fire Up Final Cut Pro and Let Her Rip

Believe it or not, you've already finished most of the work by now. First,

  make sure you have "Unlimited RT" enabled in the "RT" menu

  on the timeline, this lets third party plugins do realtime previews. Then,

  in your Final Cut Pro Project, go to the browser and open the generators tab,

  scroll down until you see "CM ImageFlow Fx".











The generators in Final Cut Pro effects browser







Now drop the "Multifader" plugin onto your timeline, then double

  click on the clip to bring it's controls up in the viewer. Click on the "controls" tab,

  and it will bring up the following menu:



Multifader control settings

Hit that choose button and use the file browser to select our "Photomontage

  selects" folder on the desktop.
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  Select the frame rate of your project (this is done automatically in FCP6),

  then hit play, you've immediately got a montage playing in real time on the

  timeline. There is a set of built in presets which set different image movements,

  try "top to bottom" and "infinite zoom" to see some different

  styles. Then, try adjusting the parameters manually, "secs per image" controls

  how long every image stays on the screen for.  "Num Images", chooses

  how many are displayed at once, up to eight. No matter how many images you

  pick it will always cycle through the images in the order that they are displayed

  in the finder folder window (and the order you selected in iPhoto).

 

 

 

 

 

 

 

 

 



Click to view the "Multifader" generator in action

You can also choose to randomize any of the x,y or z positions of each image

  by using the "random x,y,z" checkboxes, and then adjust the "random

  spread" to influence how far apart the images will be placed.

Now add a mask to each image, scroll down to the "image mask" option,

  tick the "enable mask" check box and select "Rough 02" for

  a ragged edge effect on each image. You can choose from a whole range of built

  in images or use the image well to drop your own on. Similarly, the "apply

  frame" option allows you to apply a variety of picture frames or digital

  grunge borders to the image.

 

 

 













Tip: creating generators more than two minutes long

The Final Cut Pro interface doesn't make it easy to make a generator more

  than two minutes long. If you need your Photomontage to be more than two minutes

  then do the following. Double click on the generator to bring it up in the

  Viewer window. Type in a new duration for the clip in the left hand side window

  next to the stop watch icon. Once you've changed the duration here, you can

  drag the generator out to any length, even hours long.







Moving on to more photo montage styles

Now try dropping the "Polaroids" generator onto the timeline on

  a new layer with a slight overlap. Choose the "St Petersburg Lions" folder

  or one of your own, set the project frame rate and hit play. You've just got

  a flash frame effect instantly with nice soft glowing falloff. Perfect for

  Wedding Videography. Try adjusting the time per image and "rest time".

  Rest time is the time each image will stop before the transition starts to

  the next image in the sequence. Almost all of the plugins in image flow include

  rest time as a parameter. Something else you can try, if you are editing to

  a music track and know the BPM (beats per minute) of the track then you can

  tick the "use bpm" check box and type the BPM in and the pictures

  will change on every beat, or use the BPM modifier to select "x0.25" to

  only change on every fourth beat. Again, almost all the effects include the

  BPM option, which makes things a lot easier for editing music videos.
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"Polaroids" generator: perfect for Wedding Videography

The Polaroids generator makes each image transition into the next with a flash frame effect.

TIP: Check your rendering resolution sequence settings. 

In Final Cut Pro 6.0.1 Apple has changed some defaults for some "easy setup" sequence settings to default to
Resolution "50%" of sequence frame size on final renders. This makes your final output look very blocky and rough.
Make sure you increase this back to "100%" under the "Sequence Settings -> Render Control" when doing a final render.













Two more styles, and they're free to keep

The ImageFlow Fx pack will render with a watermark after 14 days, but two

  of the effects, "Continuous Random Pan" and "Image Filmstrip" are

  free plugins which work with no watermark or expiration of the demo period.  "Continuous Random Pan" is a similar
animation style to the

  built in screen savers "Beach" or "Forest", it will dissolve

  images continuously over each over with a random direction of movement. You

  can choose to have movement only in x,y or z and also choose the spread of

  the random move using the "x,y,z range" parameters under Random Movement.







The "Continuous Random Pan" generator























"Image Filmstrip" with the Final Cut Pro "Perspective -> Curl" effect

  applied

"Image Filmstrip" generates a continuous scrolling film strip of

  images with a variety of different border styles, and you can even rotate it

  in 3D space to create some dramatic styles. The film strip is not infinitely

  long, it displays eight images at once and if you position the camera too far away, you'll see the edges fading off to
nothing. For some nice effects you can put a curl on the film strip using the built in "Effects -> Perspective

  -> Curl" effect. Or you can create a flock of film strips in 3D by

  using the "3D Image Random Spacing" filter which is included in the

  Noise Industries Motion Pack under "NI Stylize".













"Image FilmStrip" with "3D Image Random Spacing" (from

  CoreMelt Motion Pack) applied.





Experiment with the other Photomontage styles, "Liquify In" will

  dissolve images in with a liquid rippling effect, while "MultiSwoosh" let's

  you "fly" though up to eight images at one which curl off to the

  sides as they approach the viewer. With the fourteen animation styles and the

  different movement presets, images and frames there is literally hundreds of

  styles of Photomontage which you can create in real time.
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The "Liquify In" generator



"Multiswoosh" generator





TIP: All Plugins work in Motion and have better render control

If you get jagged edges or stuttering motion then try using the plugins in

  Motion instead of in Final Cut Pro. Motion gives you the option to apply Motion

  Blur or better Anti Aliasing, which both help considerably in the quality of

  the final render. These options are not available in Final Cut Pro. To access

  them, go to "Render Settings" in the Project Properties, change Anti

  Aliasing Method to "Best", and turn on Motion Blur in the "View" drop

  down on the project viewer. If going to Motion is not an option, then you can

  try using the built in "Flicker Filter" in Final Cut Pro or and/or

  apply a directional blur in the direction of your image movement.

Now let's rewind to that moment before, you're handed the CDROM of images,

  you relax, load up ImageFlow Fx and say "No Problem, why don't we try

  a few styles and see what you like?"

7PM, the job is on tape and you're out the door...



You can grab the ImageFlow sample images and project from this link, or use your own images. 



Please make sure you are running the latest version of ImageFlow, available from here.
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